Fallout Script Extender

From GECK

Revision as of 07:33, 25 March 2009 by Syn23 (Talk | contribs) (Cleaned up and updated section, removed a comment because it was redundant.)

The Fallout Script Extender, also known as FOSE, is maintained by Ian Patterson (ianpatt), Stephen Abel (behippo), and Paul Connelly (scruggsywuggsy the ferret).

Current stable version: v1
Current beta version: v1.1 beta 2
Main site: http://fose.silverlock.org
Documentation: FOSE Command Documentation
Official forum thread: Fallout Script Extender (FOSE) v1, Thread 9


How it Works (or why NOT to be afraid of FOSE)

FOSE does not edit your Fallout3.exe in any way, and as such is not dangerous to use at all. It works by running the .exe and then patching it while it is in memory in order to add in new scripting functions.

How to use FOSE with the GECK

Scripts written with FOSE's new functions must be created via the GECK after it's been loaded through fose_loader.exe. To use FOSE with the GECK:

  1. Extract fose_loader.exe and the necessary dll files to your Fallout 3 directory.
  2. Open a command prompt window and navigate to that directory.
  3. Type this into the command prompt:

fose_loader.exe -editor

A more convenient method is to automate this command through a shortcut:

  1. Create a shortcut to fose_loader.exe.
  2. Right-click on the shortcut and open the properties window.
  3. Add "-editor" to the Target field.

Note: the normal editor can open plugins with extended scripts, but will give errors if it tries to recompile them.

Compatibility

Compatible Versions

  • FOSE v1 (Stable) supports the DVD and Steam version patched to 1.1.0.35.
  • FOSE v1.1 (Beta 2) supports the DVD and Steam version patched to 1.0.0.15, 1.1.0.35, and 1.0.4.6.
Note: in order for FOSE to work properly with 1.0.0.15, a specialized dll file needs to be placed in the Fallout 3 directory. It can be downloaded here.

Incompatible Versions

  • FOSE is not compatible with the original, unpatched DVD or Steam version.
  • FOSE is not compatible with the Direct2Drive (D2D) or the Russian version of Fallout 3 protected by StarForce. FOSE will never be compatible with these versions, as they are encrypted and it would be illegal to break the encryption.
  • FOSE is currently incompatible with Windows Live, so when running via fose_loader.exe, Live will be disabled. It appears that Live periodically checks the cryptographic signature of the Fallout runtime. If the signature doesn't validate properly, Live fails. Because of this, it is unlikely that FOSE will be directly compatible with Live in the foreseeable future. However, by loading Fallout3.exe instead of fose_loader.exe, you can still download DLC and updates through Live.
Note: since Live stores save files in a separate folder when active, users will need to move their save games from their user profile folder in the My Documents folder to the main Saves folder in order to access them.
  • FOSE currently does not support the Austria/Germany versions of 1.4.0.6. If you are using Steam, make sure to temporarily disable auto-update on Fallout.
Personal tools